home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / www-client / mozilla-launcher-1.49 / mozilla-launcher-1.49.ebuild < prev    next >
Text File  |  2006-05-08  |  958b  |  37 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-launcher/mozilla-launcher-1.49.ebuild,v 1.2 2006/03/23 19:53:30 agriffis Exp $
  4.  
  5. inherit eutils
  6.  
  7. DESCRIPTION="Script that launches mozilla or firefox"
  8. HOMEPAGE="http://dev.gentoo.org/~agriffis/dist/"
  9. SRC_URI="mirror://gentoo/${P}.bz2 \
  10.         http://dev.gentoo.org/~agriffis/dist/${P}.bz2"
  11.  
  12. LICENSE="GPL-2"
  13. SLOT="0"
  14. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
  15. IUSE=""
  16.  
  17. DEPEND=""
  18. RDEPEND="|| ( x11-apps/xdpyinfo virtual/x11 )"
  19.  
  20. S=${WORKDIR}
  21.  
  22. src_install() {
  23.     exeinto /usr/libexec
  24.     newexe ${P} mozilla-launcher || die
  25. }
  26.  
  27. pkg_postinst() {
  28.     local f
  29.  
  30.     find ${ROOT}/usr/bin -maxdepth 1 -type l | \
  31.     while read f; do
  32.         [[ $(readlink ${f}) == mozilla-launcher ]] || continue
  33.         einfo "Updating ${f} symlink to /usr/libexec/mozilla-launcher"
  34.         ln -sfn /usr/libexec/mozilla-launcher ${f}
  35.     done
  36. }
  37.